WP「1つ以上の推奨モジュールが存在しません」解決方法

サイトヘルスステータスで以下の改善項目が表示された場合の対処方法です。

1つ以上の推奨モジュールが存在しません パフォーマンス

PHP モジュールはサイトの稼働に必要なほとんどのタスクをサーバー上で実行します。変更はサーバー管理者が実施する必要があります。

WordPress ホスティングチームでは、こうした推奨されていたり必須とされていたりするモジュールのリストをチームのハンドブック (新しいタブで開く)でメンテナンスしています。

警告 オプションのモジュール imagick がインストールされていないか、無効化されています。

「オプションのモジュール imagick がインストールされていないか、無効化されています。」の解決方法

この表示がされるレンタルサーバーは、さくらインターネットの共有サーバーです。

1、コントロールパネルへログイン

さくらインターネットのコントロールパネルへログインします。

2、php.iniの編集

スクリプト設定から、「php.ini設定」をクリックします。

「PHPiniファイル設定」画面が表示されるので以下のコードを追加して保存します。
※スペルミス、前後に不要なスペースがないよう注意しましょう。

extension = imagick.so

追加したら「保存する」をクリックして反映させます。

以上で完了です。

PHPのバージョン変更とは異なり即座に反映されます。
サイトヘルスステータスのエラーは無事に消えましたでしょうか?

imagickは必要か?

WordPressからの「改善提案」であり、必須ではありません。
imagickがない環境であってもWordPressは正常に作動します。
サイトヘルスステータスでも、緊急性のない「改善」として表示されるだけです。

シェアする

フォローする